Virtual device testing fails with the error: No connected devices!

#1

Description of the issue

I have added the step Android Build for UI testing and Virtual device testing and this order.
I run them at the end of the workflow and I have actually tried other configurations as well but in all the cases the step Virtual device testing fails with the error:

FAILED

FAILURE: Build failed with an exception.

  • What went wrong:

Execution failed for task ‘:app:connectedDebugAndroidTest’.

> com.android.builder.testing.api.DeviceException: No connected devices!

Environment:

Running on Bitrise with the “Android and Docker on Ubuntu 16.04” stack
The step “Virtual device testing” version 1.0.5 is failing when running the task

app:connectedDebugAndroidTest

Reproducibility:

  • _Does a “Rebuild” help? NO
  • _Does a rebuild without caches help? NO
  • Does the issue happen sporadically, or every time? : every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : since we started using this step.
0 Likes

#2

It works as intended.
You cannot make ADB connection between virtual device from VDT and Bitrise build machine.
Testing with VDT consists of building APKs, uploading them and then waiting for results.

1 Like

#3

Thank you. I have followed the tutorial here: https://devcenter.bitrise.io/testing/device-testing-for-android. Is there some other documentation about it?

0 Likes

#4

None of the steps from that tutorial should invoke app:connectedDebugAndroidTest :thinking:
It seems that you have something additional in your workflow.

0 Likes

#5

Can you please include a build URL where this issue occurred?

0 Likes

#6

Sorry for the noise. I fixed the issue. My fault.

1 Like

#7

I’m glad you could fix it! :upside_down_face:

0 Likes

closed #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes