Virtual-device-testing-for-android (exit code: 1)

Bitrise Build Issue Report template

Description of the issue

Sometimes the step fails without any error description. about 50% of the time.

Environment:

Where did the issue happen?
Android & Docker, on Ubuntu 16.04

Which build Step causes the issue and which version of the step?

virtual-device-testing-for-android v1.0.1

Reproducibility

  • _Does a “Rebuild” help? YES
  • _Does a rebuild without caches help? haven’t tried
  • Does the issue happen sporadically, or every time? : 50%
  • Does upgrading the build Step to the latest version help? : no newer version
  • When did the issue start? : since we started using this step.

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Haven’t tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( Bitrise CLI )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: Redirecting… .
Haven’t tried.

Build log

1 Like

Hi @giladgotman,

Did you check the results on the Virtual Device Test tab?