Android Virtual Device Testing fails

testing
#1

Suddenly the Android Virtual Device Testing step fails with the error: Testing add-on was not configured properly, please make sure to use the minimum required step versions described here

I could not find any useful info in the link.

This is the build https://app.bitrise.io/build/51e1c054e9631d76#.

Can you please tell me what changed?

Thank you

1 Like

#2

Hi @robertoaltieri,

Seems like this workflow is missing a Deploy to Bitrise.io step, so there is no way for the add-on to reach the results.

0 Likes

#3

Is this a recent change? I have been using the same workflow for a while and it used to work until yesterday. And the error seems to suggest a different issue.

0 Likes

#4

The error is definitely exactly suggesting this as it is a basic requirement. This isn’t recent change, there is no other solution to extract files from the Virtual Machines other than the deploy step, this is the reason this was a necessity from the get-go. Can you send us an example of a build URL where you can view the Test Reports but there is still no deploy step?

0 Likes

#5

It looks like now it is not possible to see them anymore but it was definitely possible until yesterday

0 Likes

#6

Could be possible due to some weird phenomenon I suppose, can you send me a build URL about it so we can get to a bottom of it? :slight_smile:

0 Likes

#7

Hello @bitce

I’m having the same issue.

I haven’t changed anything and it started happening for few days already

Ps. I have deploy step included

Here’s my build https://app.bitrise.io/build/d3dbc9ae211ad1f4#

0 Likes

#8

@MattNG Can you enable Support Access on this app so we can give it a thorough check please?

0 Likes

#9

Done.

Thanks for the response @bitce

0 Likes

#10

Thanks @MattNG!

We were able to confirm the issue, it’s basically happening with utility workflows which are chained together. We are working on a solution as we speak!

0 Likes

#11

I also got this error, here is my build with enable “bitrise support”:
https://app.bitrise.io/build/0847421a43cbd6cc#?tab=log

Thanks

0 Likes

#12

Hi @dat

This is expected too, because this build is missing the deploy step too.

0 Likes

#13

I’ve also started seeing issues in the past few days. My build has a deploy step, and is not part of a chained workflow.

For me, the build succeeds, and I am even getting code coverage info back from the Virtual device test run, but I just can’t see any artifacts in the Test Add-On because it shows the error listed in the original post.

Here is an example build: https://app.bitrise.io/build/114df09b59839948#?tab=log (and I’ve enabled the support user).

Some things I tried:

  • Updating all steps to use the latest version
  • Switch from using the “Gradle Runner” step to the “Android Build for UI testing” step to build the APKs (and making sure I had the module and variant values set)

As mentioned, this worked fine for me before the past few days, and then suddenly stopped working.

UPDATE: I also noticed that the Test Reports Add-on seems to be broken on older builds on which it definitely worked before (example: https://app.bitrise.io/build/6aa6d0d9347cda68#?tab=log). So, it seems like there might be an issue outside of workflow configuration?

0 Likes

#14

I keep seeing the same issue. I have added the deploy to bitrise step but it is still not working.
For example for https://app.bitrise.io/build/afd0b5a72cd0265c#?tab=log the build is failing, I guess because some tests is failing, but I can’t open the Test results page so I can’t see which test is failing.
I have also enabled the support.

0 Likes

#15

Hi @bryndsey! @robertoaltieri!

Thanks for the detailed report and really sorry about the flakiness! The issue should be completely gone by now, let me know if there’s anything odd you’re experiencing!

1 Like

#16

Thank you. it is working now

1 Like

#17

Yep, working for me as well. Thanks!

1 Like