Virtual Device Testing for Android InfrastructureFailure

android
#1

Hello,
I’m trying to launch UI tests with Virtual Device Testing on an Android app.
But this steps fails after a timeout with “Outcome” : "inconclusive(InfrastructureFailure)"

Link to my build : https://app.bitrise.io/build/ed42cd77a8b17fe3#?tab=log
I enabled Bitrise Support for my app.

For the Gradle Runner step, I tried to run tasks “assembleDebug assembleAndroidTest” and “assembleDebug assembleDebugAndroidTest”, but both failed.

For Virtual Device Testing step, my configuration is for test type “instrumentation” with a test timeout at 180 seconds (I tried more but no change).

In my app’s settings tab, I wasn’t able to activate “Android UI Testing” because I don’t see this block.

Could you please help me to run my UI tests ?

Here are the logs for this step :

±-----------------------------------------------------------------------------+

| (7) virtual-device-testing-for-android@1.0.5 |
±-----------------------------------------------------------------------------+
| id: virtual-device-testing-for-android |
| version: 1.0.5 |
| collection: https://github.com/bitrise-io/bitrise-steplib.git |
| toolkit: go |
| time: 2019-07-12T08:56:41Z |
±-----------------------------------------------------------------------------+
| |
INFO[08:56:41] Start installing (golang) with apt-get
INFO[08:56:41] * [OK] Step dependency (go) installed, available.
Configs:

  • ApkPath: /bitrise/deploy/sample-debug.apk
  • TestTimeout: 180
  • DirectoriesToPull:
  • EnvironmentVariables:
  • TestDevices:

Model API Level Locale Orientation
NexusLowRes 24 portrait en

  • AppPackageID:
  • TestType: instrumentation
  • TestApkPath: /bitrise/deploy/sample-debug-androidTest.apk
  • InstTestPackageID:
  • InstTestRunnerClass:
  • InstTestTargets:
  • UseOrchestrator: false
    Upload APKs
    => APKs uploaded
    Start test
    => Test started
    Waiting for test results
  • Validating
  • (1/1) running
  • (0/1) running
    => Test finished
    Test results:
    Model API Level Locale Orientation Outcome
    NexusLowRes 24 en portrait inconclusive(InfrastructureFailure)
    | |
    ±–±--------------------------------------------------------------±---------+
    | x | virtual-device-testing-for-android@1.0.5 (exit code: 1) | 13.3 min |
0 Likes

#2

Hi @Manon!

Unfortunately the error: inconclusive(InfrastructureFailure) implies, that there was an error during your test in the Test Lab. I’ve checked the console but I can not see any more details of your build.

Is this issue persistent and happening regularly? If so, can you please allow Support Access for us on the app?

0 Likes

closed #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes