Error when publishing to iOS App Store after successful build

I’m developing with Xcode 11 with a native iOS app. My goal is to build on Bitrise and publish the build to the App Store/TestFlight.

I ran the Bitrise code signing tool in the terminal and successfully uploaded the certificates and provisioning profiles to Bitrise.

I ran a build and it ran successfully in Bitrise.

When I try to publish to the App Store, I get an error.

The log error is below.

I have tried both auto provisioning and the manual provisioning in the workflow. I am manually publishing the app to the App Store when I get this error. I have no idea what this error means.

Thanks for the help!

[0m- JSONConfigPath:
- AccessToken: *****
Downloading file from:
[31;1mfailed to download json config file, error: failed to get response, statuscode: 500, body: {"message":"Internal Server Error"}


On another note, I sent this message to Bitrise support on April 25. On April 29 they wrote a question and I immediately wrote a response. On April 30 they wrote a message indicating some confusion - they clearly had not read the initial message. I immediately wrote back and have not heard from them as of May 2. Not sure what is going on, but as a paying subscriber I have not yet gotten this working and cannot seem to get any kind of reasonable support on the matter from Bitrise.

Sorry for the confusion around this @myeviltwin! As of me typing this, Ship is still in beta, so any reports of issues are welcome for the next phase. This too was a bug we had to fix.

For the record of anyone stumbling across this thread in the future, Ship is by now means required, you can simply use your builds to deploy from there directly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.