Gradle Runner Step failing

android

#1

Bitrise Build Issue Report template

Description of the issue

On one of my workflow used for app testing the gradle runner step is failing today. The flow was working fine until yesterday but since this morning it keeps failing.

Here is one of the build

Environment:

Where did the issue happen?
Android/Docker Ubuntu stack

Which build Step causes the issue and which version of the step?
Gradle Runner - 1.8.3

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Everytime
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Today, It was fine until yesterday!

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.
HAVE NOT TRIED

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .
HAVE NOT TRIED

Build log


#2

Hi @vintwala,

Sorry about these issues. We started looking into them, will get back to you here as soon as we can!


#3

Hello there! It seems some of your dependencies can not be downloaded through jcenter, a method to solve is to change the repositories field in your build.gradle file to

repositories {
  google()
  mavenCentral()
  jcenter()
} 

#4

@fehersanyi-bitrise That worked!


#5

Hy there! I’m glad to hear it! :slight_smile:


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.