Error 403 on subsequent Android VDT steps


#1

Description of the issue

It seems that virtual-device-testing-for-android step can run only once for given build. Subsequent steps fail with Failed to start test: 403, error: {"error":"Build already exists"}

Environment:

Bitrise.io, Android (non-LTS) stack.

Which build Step causes the issue and which version of the step?

E.g.: virtual-device-testing-for-android v1.0.3

Reproducibility

  • _Does a “Rebuild” help? : NO
  • _Does a rebuild without caches help: NO
  • Does the issue happen sporadically, or every time? : Haven’t tried more than once.
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : 2018.11.09 @ 17:52

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

N/A

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

N/A

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.
https://app.bitrise.io/build/1f962cf60e0e0e05


#2

Thanks for the report @koral! We’ll look into this as soon as possible :slight_smile:


#3

So, currently this isn’t actually an issue, it’s working as intended. VDT will send a build slug to firebase through which the build is created there, so two tests will never work in one flow due to them having the same build slug.

Although I understand why this might not be ideal, maybe it’s better to move the matter to a #feature-request? :thinking:

What do you think?


Allow multiple android VDT step invocations
#4

I understand the reason. However, shouldn’t this limitation be documented somewhere?

Feature request added: Allow multiple android VDT step invocations


#5

That’s a very good point, I pinged our tech writer team to look into this!


#6

Hi! I’m just letting you know that we documented this restriction to make sure users are aware of it. Thanks for your feedback!