[Solved]Android virtual device testing failed: (exit code: 1)

android
#1

Bitrise Build Issue Report template

Description of the issue

virtual-device-testing-for-android@1.0.5 (exit code: 1)

When I manually testing on firebase by drag & drop APK & Test APK on same config on Firebase -> UI test working normally (Running and have test report)

Environment:

Ubuntu 16

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

virtual-device-testing-for-android

E.g.: Git Clone v3.6.0

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : YES/NO
  • Does the issue happen sporadically, or every time? :
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : from begining

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried. (not yet, I will try later)

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

Build log

Thanks

0 Likes

#2

I solved problem.In my case it using wrong Test APK by using TestAPK of lib
Solution:

  1. We should check from build logs to verify we are using correct APK and test APK:

$BITRISE_TEST_APK_PATH, $BITRISE_APK_PATH

  1. Make sure assembleDebugAndroidTest task generated expected Test APK, In my case I should use assembleAndroidTest instead

That is it.

0 Likes