Google play deploy - Write failed: Broken pipe

Bitrise Build Issue Report template

Description of the issue

The Google play deploy step failed with this error:
Committing edit
Write failed: Broken pipe

The build failed but actually the deploy to google play store was successful.


Where did the issue happen?

Android & Docker, on Ubuntu 16.04

Which build Step causes the issue and which version of the step?

google-play-deploy v1.4.1


  • _Does a “Rebuild” help? YES
  • _Does a rebuild without caches help? didn’t try
  • Does the issue happen sporadically, or every time? : sporadically
  • Does upgrading the build Step to the latest version help? : NO newer version
  • When did the issue start? : today

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( Bitrise CLI )? If no, can it be reproduced with Docker (using the same docker images / environment we use on Related guide: Redirecting… .
Havn’t tried

Build log

Hi @giladgotman,

As the rebuild helped it seems more like some kind of temporary (probably network) issue…

Did you see this to happen in any other build?

Hi, thanks for the prompt reply.
Yeah it might be a temporary network issue indeed.
I will update if it happens again.
Thank you.

1 Like

Please do, thank you! :slight_smile: