Bitrise reports an error even if all the tests pass

test
firebase
android
#1

I’m using the firebase virtual device test step for Android. Everything was fine until the recent changes in bitrise.
Now the new “Test reports” reports that the tests failed even if all the tests passed.
The build is https://app.bitrise.io/build/2d90f8c8e8d1d2ef,
Can you tell me why bitrise reports the error, please?

0 Likes

#2

Hello Robert👋

From the build log unfortunately I can’t find any clue, could you please enable support user on the settings tab of the app so I could check the settings and the test results as well, and try to come up with a possible solution? :upside_down_face:

0 Likes

#3

Hello,

I go the same problem, all the test are passed, but the step is on failed and I don’t find the problem.

0 Likes

#4

Hi guys!

There seems to be a few issues with the new Testing Add-on unfortunately, we are of course looking at them as we speak! Sorry about this, will let you know once we have an update :slight_smile:

0 Likes

#5

Do you still need me to enable support user?

0 Likes

#6

I have done it

0 Likes

#7

Hy,:wave:

I checked out the test results and 3 of your cases failed because of this error lateinit property fetchedDrivingProfile has not been initialized in this file ProfileTestSteps.kt on lines 56 and 88 :upside_down_face:

0 Likes

#8

Mmm bitrise used not to show the failed tests. Now it does. Thanks

1 Like

#9

You are welcome :upside_down_face:

0 Likes

#10

I don’t know whether this i a different issue or just another side effect of the changes in bitrise. Now the tests do not run at all and I get the error:

Upload APKs

Failed to start test: 403, error: {“error”:“Unauthorized request”}

the build is

0 Likes

#11

Hi @robertoaltieri,
Thanks so much for the report. The issue you are seeing is a different one. We’re really sorry to be holding you up today! :disappointed: Please know that our Website team is aware of this issue and they are working on deploying the fix to production to get everything up and running. We will send you a follow-up message here as soon as it’s resolved. Thank you for your patience! :raised_hands:

0 Likes

#12

Hi @robertoaltieri, this issue is fixed, thanks for your patience!

0 Likes

closed #13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes