Automatic Signing - Connected Apple account not found

Bitrise Build Issue Report template

Description of the issue

I’m trying to implement automatic signing on my Ionic app iOS build step. I have used the apple-id way of connecting an Apple account and have linked it to my account correctly (it says its authenticated). Yet the build step still fails saying that the Apple service connection is not found. I tried adding the team export_development_team first as the team ID on the Apple service connection, which didn’t work then tried to use the team name, which also failed. Not sure what else I’m doing wrong. I’ve manually removed the parameter it is at the moment as I don’t want to show that information publicly.

Environment:

Where did the issue happen?

This is on a Bitrise stack: Xcode 13.0.x, on macOS 11.4 (Big Sur) on Intel and macOS 12.3.1 (Monterey) on Apple Silicon
Standard

Which build Step causes the issue and which version of the step?

The Build IOS DEV step is failing and was recently upgraded to 4.3.3

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : When trying to implement automatic signing

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried. I’ve been using automatic signing on my own Mac / Xcode to build this configuration without any problems. Linking to the same Apple account that I’ve linked to Bitrise.

Build log

Pasting the relevant part of the Build log here but can also send the url through private channel.
±-----------------------------------------------------------------------------+

| (6) Build iOS DEV |
±-----------------------------------------------------------------------------+
| id: xcode-archive |
| version: 4.3.3 |
| collection: GitHub - bitrise-io/bitrise-steplib: New Bitrise StepLib |
| toolkit: go |
| time: 2022-05-11T12:17:12Z |
±-----------------------------------------------------------------------------+
| |
INFO[12:17:15] * [OK] Step dependency (xcode) installed, available.
Inputs:

  • distribution_method: ad-hoc
  • upload_bitcode: true
  • compile_bitcode: true
  • icloud_container_environment:
  • export_development_team: [Manually Redacted]
  • export_options_plist_content:
  • log_formatter: xcpretty
  • project_path: /Users/[REDACTED]/git/ios/App/App.xcworkspace
  • scheme: DEV
  • configuration: DEV Debug
  • output_dir: /Users/[REDACTED]/deploy
  • perform_clean_action: false
  • xcodebuild_options:
  • xcconfig_content: COMPILER_INDEX_STORE_ENABLE = NO
  • export_all_dsyms: true
  • artifact_name:
  • verbose_log: false
  • cache_level: swift_packages
  • automatic_code_signing: apple-id
  • certificate_url_list: [REDACTED]
  • passphrase_list: *****
  • keychain_path: /Users/[REDACTED]/Library/Keychains/login.keychain
  • keychain_password: *****
  • register_test_devices: false
  • min_profile_validity: 0
  • BITRISE_BUILD_URL: Bitrise - Mobile Continuous Integration and Delivery - iOS & Android Build Automation
  • BITRISE_BUILD_API_TOKEN: *****
    Xcode version:
    Xcode 13.0 (Build version 13A233)
    Fetching Apple Service connection
    Bitrise Apple Service connection not found.
    Most likely because there is no configured Bitrise Apple Service connection.
    Read more: Redirecting…
    Apple ID authentication is selected in Step inputs, but Bitrise Apple Service connection is unset
    | |
    ±–±--------------------------------------------------------------±---------+
    | x | Build iOS DEV (exit code: 1) | 22.02 sec|
    ±–±--------------------------------------------------------------±---------+
    | Issue tracker: Issues · bitrise-steplib/steps-xcode-archive · GitHub |
    | Source: GitHub - bitrise-steplib/steps-xcode-archive: Xcode Archive for iOS step |
    ±–±--------------------------------------------------------------±---------+

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - Contact us ), with a link to the related Discuss issue.