No development nor production certificate identified on development portal


#1

Bitrise Build Issue Report template

Description of the issue

Please describe the issue here
Earlier it was working fine. Since few days I am not able to deploy builds. I didn’t change anything in the setting of Bitrise or Apple Developer & Apple Connect account. I am not able to identify the issue. Attaching screenshot for the more details.

Environment:

Where did the issue happen?

Stacktrace (for debugging):
/private/var/folders/90/5stft2v13fb_m_gv3c8x9nwc0000gn/T/bitrise250846822/step_src/lib/autoprovision/certificate_helper.rb:166:in `identify_certificate_infos’

Which build Step causes the issue and which version of the step?

ios-auto-provision 1.3.0

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : It was working perfectly before 10 Feb 2019. I created a build on 14th Feb and it failed.

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

Build log


#2

Hello there!

For the first thing I would recommend re adding your apple account to bitrise, there were some changes to the terms and agreements, this could solve the issue.


#3

Already tried… but no luck :frowning_face:


#4

Hi agian @raviagrawal!

I’ve closed our thread since you didn’t appear to be active on this issue, but we find it really hard to pin down the exact issue about this since we have no option to see into your Apple Dev configuration, but we are really certain that this is related to roles on the Portal and/or App Store Connect.


#5

Thanks bitce.
I have changed the apple account of admin in Bitrise and that seems working fine.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.