"No Apple developer account found for this build" but account is already connected

ios
#1

Hi! Bitrise is such a cool service!

I’m trying to get autoprovisioning working, following the excellent instructions at https://app.bitrise.io/app/3d88872312625036/workflow/code_signing_wizard.

I’m having the identical error message as reported in this question: Major Noob reporting for duty sir! Simple iOS setup not working

which is the following:

Error:

No Apple developer account found for this build.

Stacktrace (for debugging):

/private/var/folders/6q/wgy6jtp12w5gzgm9lzcglpqw0000gn/T/bitrise844948834/step_src/lib/autoprovision/auth_helper.rb:61:in `get_developer_portal_data'

/private/var/folders/6q/wgy6jtp12w5gzgm9lzcglpqw0000gn/T/bitrise844948834/step_src/lib/autoprovision/auth_helper.rb:20:in `login'

/var/folders/6q/wgy6jtp12w5gzgm9lzcglpqw0000gn/T/bitrise844948834/step_src/step.rb:25:in `<main>'

This is in the ios-auto-provisioning step.

Here’s what I’ve tried:

  1. My Apple Developer Account is already connected.
  2. I have two teams on my account, so I also added the Team ID to the workflow step.
  3. I also tried changing the scheme name in the workflow step, from $BITRISE_WORKFLOW to a literal that matches the scheme in my workspace.

Still no luck!

How can I resolve this?

0 Likes

#2

Hi @paulmelnikow!

Have you also tried the solution in the thread you’ve pasted? :slight_smile:

You have to select your account in the Team tab of your app for your builds to be using it.

0 Likes

#3

Ha! I see now, thanks!

Even though I found that issue it wasn’t clear from the screenshots that it needed to be done under the app (though it was there in the text).

Screenshot, in case it helps someone else:

I’d highly suggest adding that step to the end of your Code Signing Wizard.

Thanks again!

1 Like

closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes