Your account already has an Apple Development signing certificate for this machine

Bitrise Build Issue Report template

Using Xcode Archive & Export for iOS I choose the option Automatic code signing method to use api-key as recommended, the first time I got a success but after this every time bitrise claims “Your account already has an Apple Development signing certificate for this machine, but its private key is not installed in your keychain. Xcode can create a new one after revoking your existing certificate.” so I have to go on Apple and revoke the certificate that was created by api-key.

Description of the issue

Please describe the issue here


Where did the issue happen?

If on which stack? If not on on what operating system? (Plus any other information you can share)

Which build Step causes the issue and which version of the step?

E.g.: Git Clone v3.6.0


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : YES/NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : YES/NO
  • Does the issue happen sporadically, or every time? :
  • Does upgrading the build Step to the latest version help? : YES/NO
  • When did the issue start? :

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( Bitrise CLI )? If no, can it be reproduced with Docker (using the same docker images / environment we use on Related guide: Running your build locally in Docker - Bitrise Docs .

Build log

Please copy paste the build’s URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - Contact us ), with a link to the related Discuss issue.

+1, i think this is bitrise problem

I have the same problem, even though I follow the configuration recommended by the official documentation step by step, nothing works. I hope they offer some solution.

It happened to me too, but in my case, it only occurred when I have “main” as target branch on the trigger map on bitrise.yml. As soon as I changed the target branch into any other branch, the build worked successfully. I think this is a Bitrise bug, hope they release a solution or updates.

@gekkostudio how did you trigger the build?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.