Xcode archive: Use dot instead of slash in app ID


#1

Bitrise Build Issue Report template

Description of the issue

Currently, to determine which provisioning profile to use the team ID and the bundle ID are concatenated using a / , e.g. HTUG78SA74/com.example.myapp . Is it possible to use a . instead as a separator? All of our provisioning profiles use a dot in the App ID property. I am new to Bitrise and maybe I overlooking a config possibility.

Environment:

Where did the issue happen?

Xcode 10.0.x, on macOS 10.13 (High Sierra)

Which build Step causes the issue and which version of the step?

xcode-archive@2.4.15

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Existed from the beginning, since I signed up for Bitrise last Week.

Local reproduction

It works locally, becuase Xcode searcher for the proper App ID.

Build log


#2

Hi @matoilic!

I might be missing something, but I don’t see what you’re raising here to be the issue, in the log attached, you do not have a step configured for signing, so the errors you are receiving are expected. Could this be the issue itself, or perhaps do you have a build URL that could exemplify this better?


#3

I made a really stupid mistake here. I thought that the uploaded certificates and provisioning profiles would be installed automatically. I did not include the associated install step. I oversaw the mention of that in the docs.


#4

So did you guys manage to solve the issue? :slightly_smiling_face:


#5

Yes. Everything works fine now. I think we’ll get a subscription soon :slight_smile:


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.