Workflow - Abort via Bitrise DEN (timeout)

Bitrise Build Issue Report template

Description of the issue

Please describe the issue here

I have been trying to build my app on bitrise for a few weeks now and it always times out.

Environment:

Where did the issue happen?

Workflow run times out

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Which build Step causes the issue and which version of the step?

Task :app:bundleReleaseJsAndAssets

E.g.: Git Clone v3.6.0

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : It never worked

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Works on my machine

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( Bitrise CLI )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: Redirecting… .

No works on my local

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - Contact us ), with a link to the related Discuss issue.

Hi @jsuarez, :wave:

It seems your build times out at the 30-minute mark, which is due to an account limitation.

You are currently building under a free, Hobby plan. The reason behind the "Timeout after 1800 seconds " error message would be that you are limited to a 30 minute build time on a free plan (which you are on, with your personal account).

If you’re just on the edge of limitation, I’d suggest trying to invite at least a friend! For every successful referral, you get 5 minutes of extra build time, up to a total of 50 minutes. You can read more about it here: Bitrise | Extra minutes on hobby plan!. You’ll be granted an additional 5 minutes when a user you invited has added an app and run at least one successful build. With four referrals you can extend your build time to the maximum of 50 minutes/build. For the fifth, you’ll get the tee. Your invitees and their progress will be displayed on your referrals page where you can see how far along they are.

Additionally, you can get a $25 discount for every single month on a paid subscription plan forever if you contribute to a Bitrise step: you can read a how-to guide here: Bitrise Contributors

Alternatively, you can upgrade to a paid plan for more build time. You can check out our Pricing page here.

Let me know if you have any further questions. :blush:

~ Kata

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.