Webhook build triggers failing since 2nd of March

Bitrise Build Issue Report template

Description of the issue

Please describe the issue here
Our build triggers using GET https://app.bitrise.io/app/$APP_SLUG/build/start.json have been failing since 2nd of March with a 400 - “Invalid request: does not contain a ‘payload’, or it is not a valid JSON request”.


GitHub Actions & MacOS Sonoma 14.2 shell

Where did the issue happen?

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)
GitHub Actions running Ubuntu latest
curl command on MacOS Sonoma 14.2 shell

Which build Step causes the issue and which version of the step?

E.g.: Git Clone v3.6.0

HTTP request to start the build


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : YES/NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : YES/NO
  • Does the issue happen sporadically, or every time? :
  • Does upgrading the build Step to the latest version help? : YES/NO
  • When did the issue start? :

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: Running your build locally in Docker - Bitrise Docs .

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - Contact us ), with a link to the related Discuss issue.


The same problem on our end, the same curl which was working last week (returning {"status":"ok","message":"webhook processed","slug":"...} ) is constantly failing with the same error:
{"error_msg":"Invalid request: does not contain a 'payload', or it is not a valid JSON request"}

Same problem here.
The curl given by a manual Bitrise build in the advanced tab also fails with the same error.

1 Like

I’ve opened a support ticket. Let’s hope it will be picked up soon. This is impeding our development workflows significantly.


The same is happening here as well. I have notified them in Slack too. Let’s see.

Until they fix it, I manually take out builds by the console.

According to the support response, and also verified, adding -H "Content-Type: application/json" fixes the issue.


Yeah it worked this way now. Thanks for sharing :+1:

Thanks for sharing @mhanika - it’s working on our side too.

Would be amazing if Bitrise team could give us a heads up for what is arguably a breaking change :+1:

Hi Bitrise community,

This is Albert from the Bitrise support team. We were made aware of an error that caused builds to stop triggering over the weekend. We apologize for any inconvenience caused during this time. Our team of engineers investigated the issue and has now released a fix which reverted a change we made on Friday. We thank you for your patience.

Happy building,


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.