Git Clone producing get rev-list error

Bitrise Build Issue Report template

Description of the issue

Please describe the issue here

I did a force push to one of my branches. now my build fails during the git clone step and no longer works during this step.


Where did the issue happen?
this happens only on bitirise.

If on which stack? If not on on what operating system? (Plus any other information you can share)

Which build Step causes the issue and which version of the step?

E.g.: Git Clone v3.6.0


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : YES
  • Does upgrading the build Step to the latest version help? :NO
  • When did the issue start? : 04/01/2020

Local reproduction

_Can it be reproduced on your own Mac/PC by following our local debug guide?

Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what will get when it does a git clone in the clean environment! If possible please note which sections you tried._

  • tried locally
  • tried using bitrise CLI

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( )? If no, can it be reproduced with Docker (using the same docker images / environment we use on Related guide: .

Build log

build url:

Discuss issue._

Hi @matthew-open,

Can you please explain the purpose of the script happening before the git-clone?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.