Unable to install fortawesome with yarn step 404 NOT FOUND

step
#1

Bitrise Build Issue Report template

Description of the issue

Everytime i try to do yarn install via a yarn step , i keep getting the following error:

error An unexpected error occurred: “https://npm.fontawesome.com/1599D81E-780C-408B-A72C-51040C63B34C/@fortawesome/free-brands-svg-icons/-/free-brands-svg-icons-5.11.2.tgz: Request failed “404 Not Found””.

I already tried to yarn cache clean and other configurations described in their (fortawesome) docs, but i had no success.

My related deps in package.json are

    "@fortawesome/free-brands-svg-icons": "5.9.0",
    "@fortawesome/pro-light-svg-icons": "5.9.0",
    "@fortawesome/pro-regular-svg-icons": "5.9.0",
    "@fortawesome/pro-solid-svg-icons": "5.9.0",

Environment:

Bitrise Stack: Xcode 11.1.x, on macOS 10.14.6 (Mojave)

Which build Step causes the issue and which version of the step?

Yarn 0.1.0 (Latest)

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Everytime
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Nov, 22, 2019

Local reproduction

It works well locally on Mac OS Catalina

Build log

0 Likes

#2

I am getting this issue too.

Working on my local machine running Mojave (10.14.6), but failing on Bitrise at the Yarn step.

0 Likes

#3

Hey, sorry for the delay on this!

@glenmasters, could you please share the url of your build?
Also, @danielabravo and @glenmasters could you guys enable Support Access (https://devcenter.bitrise.io/troubleshooting/enabling-bitrise-support-user/) so that we may take a more extensive look? :slight_smile:

0 Likes

#4

I believe my problem was caused by font-awesome changing their authentication. On my local machine the old method was cached, but because the bitrise build was new it was re-authenticating and failing.
I went through these instructions afresh: https://fontawesome.com/how-to-use/on-the-web/setup/using-package-managers
I then deleted my yarn.lock and node_modules and executed a fresh yarn pull. I checked in the modified yarn.lock and my bitrise build worked again.
All good now.

0 Likes