Issue with Stripe & Xcode 10

ios

#1

Bitrise Build Issue Report template

Description of the issue

Migrated my project from Xcode 9.4 to Xcode 10/10.1 to use some newer pods. Stripe previously build fine in 9.4, but is now coming up with an error when built in 10 (latest version, and same version as the 9.4 builds).

ld: symbol(s) not found for architecture x86_64
:x: clang: error:

Error only occurs when building on Bitrise. Using Xcode locally does not produce the same error.

Environment:

Bitrise - Xcode 10.1 stack

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Which build Step causes the issue and which version of the step?

xcode-test@2.0.0

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Every Time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Immediately upon upgrading to Xcode 10. Downgrading the code & pods back to 9.4 will allow them to work again.

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Yes. Build using the Bitrise.yml yielded the same crash.

Build log

https://app.bitrise.io/api/build/de3e045b948d4db0/logs.json?&download=log


#2

Hy there!

unfortunately we can’t open the logs like this, if you could send us the url of the build in question that would be a big help :upside_down_face:


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.