Networking issues?

#1

Bitrise Build Issue Report template

Description of the issue

Initially it started when aborted last build b/c of lost connection to build agent.

Now it fails on yarn step

Environment:

Where did the issue happen?

bitrise.io – Xcode 10.2.x, on macOS 10.14 (Mojave)

Which build Step causes the issue and which version of the step?

yarn@0.0.8

Reproducibility

  • Does a “Rebuild” help? : NO
  • Does a rebuild without caches help? :NO
  • Does the issue happen sporadically, or every time? : every time
  • Does upgrading the build Step to the latest version help? :NO
  • When did the issue start? : An hour ago probably.

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.
https://app.bitrise.io/build/aa838248c9096c36#?tab=log

0 Likes

#2

Hi @alex.yanitskiy!

Sorry for the inconvenience and thanks for the report! We’re looking into this ASAP!

0 Likes

closed #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes

#4

Hi again @alex.yanitskiy!

We haven’t had any report on the while, but just to be sure the latest version of the step will include the --network-timeout user input by default, and the step will also print out this and possible solutions when experiencing timeouts :slightly_smiling_face: Hopefully this will be enough and prevent anyone from experiencing this in the future.

Let me know if you have any questions related to this and anything else! :slightly_smiling_face:

0 Likes