UI tests failing on AVD every time

Unable to pass the UI tests we have as part of our TestSuite. I am using a GradleRunner task to initiate the UI testing on the AVD, however all the fail with same error below:

java.lang.RuntimeException: Waited for the root of the view hierarchy to have window focus and not request layout for 10 seconds. If you specified a non default root matcher, it may be picking a root that never takes focus. Root:

Also, the same workflow works fine on my machine if I run it locally and all the test cases pass.

Any help would be appreciated to resolve this issue.

Gradle runner task

  • gradle-runner@1:
    inputs:
    - gradlew_path: “$PROJECT_LOCATION/gradlew”
    - retry_on_failure: ‘no’
    - gradle_options: ‘’
    - gradle_task: “${MODULE}:connectedDebugAndroidTest ${SMOKE_SUITE_PACKAGE}”

Stack Info
meta:
bitrise.io:
stack: linux-docker-android-20.04
machine_type_id: standard

Hello @vikramparimi :wave:

Can you please send us the log file or the URL of the related build and also enable Support Access on the Settings tab of the app ( Enabling the Bitrise Support user for your app | Bitrise DevCenter ) so that we can take a more in-depth look? :slight_smile:

Here you go :slight_smile:

Build - https://app.bitrise.io/build/348de028c0d48692#?tab=log
Support User - Enabled

Thank you @vikramparimi :slight_smile:

I checked in with the developers and this seems to be connected to an issue with the step, which they are aware of and are working actively on solving. Currently the next step comes when the next stack update happens, so this should be handled soon! :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.