Solution for convoluted Service Key JSON issue in Deploy to Google Play step

Hey guys,

So this is in reference to the issue described here: How to handle Google Play service JSON key in the latest Deploy to Google Play step?

Like @bitce suggested, I’m opening a feature request about this. I can think of two possible solutions (but of course it’s totally up to you guys how you want to solve this):

  1. Change the service key JSON file URL input in the Play Store Deploy step back to a regular input instead of a secret input. (Since the solution used in the thread linked above kind of invalidates the point of having a secret input instead of a regular input.)


  1. Allow Generic File Storage to optionally create secret variables for the URLs instead of only regular environment variables.

And thanks @bitce for all the time you put into helping with this! I really appreciate it! :smiley:

Hi @tallpants!

Thanks for the request!

I would definitely vote for option 2 here since it makes sense generally for this URL to be a secret, it’s the current expected operation which renders this sort of invalid. What do you think?

1 Like

Totally fine with either approach – whatever makes more sense or is easier for you guys to implement!

Option 3. keep input sensitive (so user won’t be able to hardcode URL in config using workflow editor) but allow env vars processed before secrets to be chosen as a value just like secrets.

Thanks for the input @koral!

We are in fact working on something that would resolve this issue in a very convenient way. We have noted this thread internally and will update you guys once it’s being implemented! :slightly_smiling_face:

New Workflow Editor version released with this feature :slight_smile: Whenever inserting values for sensitive inputs, you can now also select from the env vars related to the uploaded files: