Google-play-deploy failed

Hi Bitrise Team,

I’m having an issue with google play deploy. The issue is:

Issue with input: No JSONKeyPath nor P12KeyPath provided
google-play-deploy@1.1.0 (exit code: 1)

How can I solve this ? Is there any place to configure this ?
How can I make the automatic build to deploy to my google play store account ?

Thanks in advance,
Miguel

1 Like

Hi @miguelfreitas,

It seems you did not provide the required key file for the step.

Please follow the description of the step to generate a key file if you don’t have one already; if you have it:

  1. If you store it in your repository (you should not, in general!) you can provide the path as noted in the description of the Service Account JSON key file path input (For local JSON key file provide file path url. (ex: file://PATH/TO/key.json).
  2. Or better, use the Generic File Storage feature of bitrise.io to store the file. As you can see in the guide I linked, Generic File Storage provides an environment variable for the uploaded file, which then can be used as the value for the Service Account JSON key file path input directly. The Environment Variable will point to a time limited / expiring download URL (more info in the linked devcenter guide).

If you have any questions please let us know!

2 Likes

Hi Viktor,

First of all, thank you for your faster answer.
Unfortunately I can’t access the Workflow Tab because it is disabled, as shown in the following image.

Why that happens ?

Best Regards,
Miguel

You have to be an Admin in the app’s Team to be able to change its settings, including the workflow. The owner and admins of the app can manage access right on the Team tab.

Hi @viktorbenei
How to get Service Account JSON key file?

@Scorpion just follow the guide in the step’s description - you can see that on the UI, as well as here in the step’s definition: https://github.com/bitrise-steplib/steps-google-play-deploy/blob/master/step.yml#L3

1 Like

thank @viktorbenei

1 Like