Google Play Deploy json key error


I’m trying to get the Google Play Deploy step to work, I have uploaded the json key file to the Generic File Storage and I used the env variable that was created as input for the JsonKeyPath param, but when I run my build I get this error:

Failed to create auth config from json key file, error: No file found at path: [REDACTED]

I tried looking into the source of this step without finding anything that could help me identify the problem, so any help is appreciated. Thanks

Hello there!

Could you please send us the url of the build, so we can check the full logs for some more details? :upside_down_face:

Hi, I’m not Viki, but we are working on the same team.

Here is the build url

1 Like

Hey @fehersanyi-bitrise, do you have any suggestions for us?

Hy @viktordoktor!

Are you sure that the path you set for the json file is correct? because the build can not find it.


we don’t specify the path manually, we used Generic File Storage to upload the json file, and then used the generated environment variable as input for the Google Play Deploy step.

You will need a file downloader step to get it to the virtual machine! I just realised it is not there.

That sounds like a bit of a workaround though, right? The Google Play step is supposed to do the downloading for us. At least that’s what I understand from reading the code here:

No, unfortunately it is not working that way :thinking:
Here is a devcenter link on using the generic file storage:

Alright… In that case the documentation here should probably be updated. =)

Thank you for the heads up, we will look into this! :upside_down_face:

Hey @fehersanyi-bitrise. I finally managed to get it working. The documentation on the Google Deploy step was correct and there was no need to add an extra step to get the json downloaded.

The issue was that we had an extra secret env var (with the value asd) called $BITRISEIO_SERVICE_ACCOUNT_JSON_KEY_URL which overrode the generic storage env var with the same name. Once I removed that env var the Google Deploy step downloaded the json as expected and now we have the bundle in Google Play. =)

1 Like

Hy @viktordoktor

I’m glad you figured this out. :upside_down_face:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.