iOS build fails because of missing provisioning profiles

Bitrise Build Issue Report template

Description of the issue

Our pipelines are broken without changing the workflow (only switched from apple id to API key).
We always get the issue:

error: No profiles for ‘…’ were found: Xcode couldn’t find any iOS App Development provisioning profiles matching ‘’

Which is weird because they are still uploaded on bitrise and valid.

Environment:

Where did the issue happen?

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Xcode 13.2.x on macOS 12.0 (Monterey)

Steps in the workflow:

  1. Activate SSH key
  2. Git Clonse
  3. Brew install
  4. Certificate and profile installer
  5. Cocoapods install
  6. Fastlane

Which build Step causes the issue and which version of the step?

Fastlane 3.3.x

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does the issue happen sporadically, or every time? : every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : No idea

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

I tried this and everything works. I think it has something to do with getting the provisioning profiles from bitrise.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( Bitrise CLI )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

No it works on my own computer. I think it has something to do with getting the provisioning profiles from bitrise.

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - Contact us ), with a link to the related Discuss issue.