Getting gateway timeouts when downloading android deps via gradle build

#1

Bitrise Build Issue Report template

Description of the issue

For the past few hours our Android builds have been failing due to not being able to downloading dependencies during the gradle build step.

Could not resolve com.android.tools.lint:lint:24.3.1.
Could not get resource ‘https://jcenter.bintray.com/com/android/tools/lint/lint/24.3.1/lint-24.3.1.pom’.
Could not GET ‘https://jcenter.bintray.com/com/android/tools/lint/lint/24.3.1/lint-24.3.1.pom’. Received status code 502 from server: Bad Gateway

When we try to rebuild it, at each rebuild it fails for different deps, but I can access those urls and download from a local machine no problem.

Environment:

Where did the issue happen?

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Android & Docker, on Ubuntu 16.04

Which build Step causes the issue and which version of the step?

Fastlane android check (always latest version), during the gradle build step

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) :
    NO, rebuilt ~10 times, same error but happens randomly in terms of which deps

  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO

  • Does the issue happen sporadically, or every time? : Every time

  • Does upgrading the build Step to the latest version help? : NO, set to always use latest

  • When did the issue start? : Since our first build today, so at least a couple of hours

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

No. building it locally using fastlane works every time.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .
NO

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.



0 Likes

#2

Apparently the jcenter maven repo is having issues… nothing to do with bitrise it seems

Edit: was able to reproduce the issue locally

0 Likes

#3

Hi @aryo ,
Yes, We see that there was an outage on jcenter: https://status.bintray.com but it appears to be solved at 05:09 utc. Are you still seeing issues with android dependencies?

0 Likes

#4

All fixed now, thanks

0 Likes

#5

Awesome! Thanks for confirming! :nerd_face:I’ll be closing this thread then, but if you’d have any issues or questions feel free to open a new ticket either here or on our on-site chat!
Happy Building! :rocket::muscle:

0 Likes

closed #6
0 Likes