Gradle runner step complains that MyApp/build.gradle is not found

Bitrise Build Issue Report template

Description of the issue

For some reason, after some step organizations, my gradle runner step is no longer running.

Each time I run it, it complains that:

Issue with input: GradleFile does not exist at: MyApp/build.gradle

I tried to add a script step, and i simply did “ls ./app/MyApp” and I can clearly see build.gradle and gradlew all sitting there.


Where did the issue happen?

Android & Docker, on Ubuntu 16.04

Which build Step causes the issue and which version of the step?

Gradle Runner 1.8.3


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : EveryTime
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : After I made some step rearrangements

Local reproduction

_Can it be reproduced on your own Mac/PC by following our [local debug guide]

I will try to do that

Local reproduction: Linux / Android (docker based) stack builds

Locally it builds. Like I said, the files were there =/

Build log

1 Like

Based on your script, the path to the build.gradle should be app/MyApp/build.gradle instead of MyApp/build.gradle in the Gradle Runner step.

Let us know if you’d have any questions! :slight_smile: