Failed To Open Project, No file found at Path

Bitrise Build Issue Report template

Description of the issue

I’m trying to get a build for iOS using the Xcode export Archive but I’m getting Failed to open project: /Users/vagrant/git/MyProject.xcworkspace: No file found at path: /Users/vagrant/git/My_Project.xcodeproj/project.pbxproj

Notice the underscore between words.


Where did the issue happen?

If on which stack? If not on on what operating system? (Plus any other information you can share)

It fails at the Xcode Archive & Export for iOS no matter the version


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : ALWAYS
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : SINCE I ADDED THE XCODE ARCHIVE STEP

Hi @Daniebro :wave:

Can you please send us the log file or the URL of the related build and also enable Support Access on the Settings tab of the app ( Enabling the Bitrise Support user for your app | Bitrise DevCenter) so that we can take a more in-depth look? :slightly_smiling_face:

Sure @Roland-Bak , here it is Thanks :smiley: Bitrise - Mobile Continuous Integration and Delivery - iOS & Android Build Automation

Hello @Daniebro :wave:

I checked logs and found that the Xcode Archive is looking for Asistente_Compras.xcodeproj/project.pbxproj, but there is no Asistente_Compras.xcodeproj folder.

I did a rebuild with remote access to see what folders are in the project and found that the folder name is AsistenteCompras.xcodeproj, without an underscore.

Is it possible that this was given incorrectly, or there was a change that has not been updated everywhere? :slight_smile:

Hello :smiley:

@Roland-Bak I have searched everywhere in the project but didn’t find any reference for Asistente_Compras, and I do not know if there was a refactor in the past, this is a legacy code. Also, local archives seem to be working fine.

Hello @Daniebro,

Sorry to hear that, inheriting code is a difficult situation.

What I can suggest in this situation is to try and debug this project in a local environment: How to debug your build locally / "It works on my Mac/PC but not on" :slight_smile:

@Roland-Bak Heello :smiley:,
Same result on local, I even changed the app name in another branch and tried the same Workflow with the following results: Bitrise - Mobile Continuous Integration and Delivery - iOS & Android Build Automation

Hey there @Daniebro, that is very curious :thinking:

Could you please submit a ticket to Bitrise at Bitrise, with your findings? The experts will take a look at your build and see what can be done :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.