Error during SonarScanner execution

Is anyone else having issues with Sonar Scanner failing on Bitrise starting on 2023-08-29T05:00:00Z?

Starting on the morning of 2023-08-29T05:00:00Z Sonar Scanner began failing to perform analysis on our iOS project with a mix of Swift and Objective-C. The error given is

ERROR: Error during SonarScanner execution 
The compiler execution timed out, make sure that: 
* the analysis is running on appropriate hardware 
* eventual compiler license check over network is not taking too much time

This happens when using the SonarScanner step from the Bitrise library or when invoking sonar-scanner directly in a bash script.

I did the following to try to identify the issue.

  1. Verified that when using the same settings and code, SonarQube’s sonar-scanner works as expected on local machines
  2. Upgraded the version of SonarScanner used by the Bitrise build step
  3. Ensured Java 17 was in use by setting the java version prior to running
  4. Verified all sonar properties were correct
  5. Switched from using the build step to a script step and invoked the pre-installed sonar-scanner.
  6. Switched to the Intel based Mac stack.
  7. Ran the same workflow and commit that worked in days prior

All of these produced the same errors.

I also used the bitrise CLI tool to run my workflow locally and it worked as expected. I filed a support request with Bitrise ( #42208) and am waiting to hear back.

1 Like