Deploy to iTunes Connect - Invalid Provisioning Profile


#1

Hello, I have been trying to setup automated deployment for a React Native project. The Android side of things was simple enough, but i’m having a really hard time with iOS.

I have been receiving the following message “Invalid Provisioning Profile…”. As far as I can tell, I have the correct certs uploaded to bitrise, I have even revoked and replaced the distribution cert and reuploaded to little success.

I have done it both manually, and using the codesigndoc tool. I am able to build and distribute from my machine. Any help would be greatly appreciated! Thanks


#2

Hi @bigescalade,

Can you please send us a build URL about the issue?


#3

Hello @bitce thanks for the reply. Tried adding the build URL here but that didn’t work (I assume for security) so I will email the build URL along with a reference to this post.


#4

Of course! After looking at this the error also details A Distribution Provisioning profile should be used when submitting apps to the App Store.

In most likely event I believe the issue is that you are missing a Distribution profile.


#5

Just double checked, the provisioning profile has definitely been uploaded. I have tried uploading it using both manual methods and codesigndoc methods.


#6

Do you have a more up-to-date log perhaps in that case? It is apparent from the log that you have 4 profiles uploaded, 2 development, 1 ad-hoc, and 1 app-store, there aren’t any Distribution present


#7

Right, I have 4 provisioning profile files uploaded, and then 3 code signing identity files uploaded.

So its my understanding that the provisioning profile will be app-store and then the code signing identity is where the distribution certificate will be? That’s how I have it setup right now.


#8

Hi again!

Sorry for the confusion, looking at this, the reason for the error is clearly that you are using a development export type on the Xcode-Archive step, which conflicts with the app-store intention.

The build URL did work by the way! Discuss displays them as if they were general login links, but we can access them, don’t worry :slight_smile:


#9

Happy new year! Sorry for belated reply, went on holidays and then had a backlog on return lol.

Thanks for your help! That does indeed seem to be the problem. I have done further builds which fail (but for a different reason, which is an easy fix).

Appreciate the support


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.