Cordova build failing in cordova archive step


#1

Bitrise Build Issue Report template

Description of the issue

Cordova app build is failing during the cordova archive step, but was working on Friday Sep 28. No change in the build steps and the version number of all the steps are unchanged. Since this step is failing no apk or ipa files are generated

Its failing with the following errors:

Non-system Ruby in use. This may cause packaging to fail.
If you use RVM, please run rvm use system.
If you use chruby, please run chruby system.
error: archive not found at path ‘/Users/vagrant/git/platforms/ios/[REDACTED].xcarchive’
** EXPORT FAILED **

This is Cordova 8.0.0

Environment:

Where did the issue happen?

Hybrid (Xamarin, Ionic, …) on macOS, includes Visual Studio for Mac, Stable channe

Which build Step causes the issue and which version of the step?

Cordova Archive

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : YES/NO
  • Does the issue happen sporadically, or every time? : Everytime
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Noticed it Oct 2 (last worked Sep 28)

Local reproduction

_Can it be reproduced on your own Mac/PC by following our [local debug guide]
Cannot be reproduced locally (cordova build & cordova compile both run fine locally)

Local reproduction: Linux / Android (docker based) stack builds

n/a

Build log


#2

Hello there! could you set the stack to the previous hybrid one?


#3

I tried the ‘previous hybrid’ stack. Its failing with a different error now for the same cordova archive [1.1.1] step. Tried the build couple of times.


#4

@fehersanyi-bitrise, I’ve facing same error after 2’oct, last 26 Sept. build work fine.
Also attached image with build success and fail status.

Please suggest me solution, As soon as possible.

Thanks


#5

Hey there! could you send us the build log in email or via Intercom through the webpage? (chat icon, lower right corner)


#6

Hi @fehersanyi-bitrise,
Please check chat, I’'ve drop log details.
Thanks


#7

I dont really see anything, where did you send it? this is the one I was referring to


#8

Please check here …


#9

Hello @fehersanyi-bitrise,
Any update for resolve this issue ?
Thanks


#10

Hi @fehersanyi-bitrise,
I’ve got solution after add “–buildFlag=’-UseModernBuildSystem=0’” in Cordova archive add Options to append to the cordova-cli build command section.


#11

Glad to hear it works!


#12

Appreciate sharing that solution @arpitd

Details on this cordova-ios workaround:


#13

Note that for ionic, as per @smartorder 's link above, you need to use exactly:

-- --buildFlag="-UseModernBuildSystem=0"

#14

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.