Ionic build fails on: platforms/ios/cordova/node_modules/.bin/ios-sim


#1

Bitrise Build Issue Report template

Description of the issue

Ionic build fails after installing Cordova:
> cordova platform add ios --save

Using cordova-fetch for cordova-ios@4.5.5

Adding ios project…

Creating Cordova project for the iOS platform:

Path: platforms/ios
chmod: File not found: /Users/vagrant/git/platforms/ios/cordova/node_modules/.bin/ios-sim

Environment:

Bitrise stack: Xcode 9.4.x
If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)

Ionic Build iOS
E.g.: Git Clone v3.6.0

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : YES
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : last week

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.
https://app.bitrise.io/build/7db3d8b4f91227f3


#2

Hello @alonrosenfeld!

it seems that a npm package is missing calles ios-sim, and I am pretty sure that you did not use it knowingly.
I think some third party dependency change is the cause of this error. I would suggest installing ios-sim first and see what happens.