Failed to get cordova version


#1

Bitrise Build Issue Report template

Description of the issue

Failed to get cordova version, error

Environment:

Bitrise Default Hybrid Stack

Installing local ionic cli
$ npm “install” “ionic@latest”
Failed to get cordova version, error: failed to parse version: 8.1.1 (cordova-lib@8.1.0): Malformed version: 8.1.1 (cordova-lib@8.1.0)

Ionic Build

Reproducibility

  • _Does a “Rebuild” help? NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : YES
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? :

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Works locally on Mac machine

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

Works locally on Mac machine

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.
https://app.bitrise.io/build/dadec1af89e2ea0e


#2

Sorry to hear about the issue @alonrosenfeld, we’ll start looking into it and get back to you as soon as we can!


#3

Hi @alonrosenfeld,
Could you enable support access to the app and may I start a few test builds to investigate the issue? (you can find a guide here on how to enable support user: https://devcenter.bitrise.io/troubleshooting/enabling-bitrise-support-user/ )


#4

done, thanks!


#5

Hello there! @alonrosenfeld I don’t know if the issue is solved or not, just wanted to follow up.
are the builds running now?


#6

Partially, I managed to run iOS only using Cordova version 8.0.0 and NOT latest.
Android now fails for various reasons that I couldn;t figure out yet such as:

Could not resolve all files for configuration ‘:app:releaseCompileClasspath’.

Obviously this is very frustrating and since time is an issue I’m back to building versions manually for now…


#7

Hello there! could it be that there is a dependency from jcenter() that it does not find? if yes, thn you can solve it to put google() in the first place in the build.gradle files repositories.


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.