Carthage in Xcode 12 is never cached

I’ve recently just upgraded to Xcode 12 and I see that there is a workaround for a Carthage issue where we should use a custom xcconfig file to exclude the arm platforms. After I did that, I find that Carthage is now no longer being cached. So the cache-pull and cache-push steps are not exactly working right. The consequence is, it took an additional 25 minutes for every build to run now. And now every build will last for 50 minutes or more. Is this expected? How do I fix this?

Thanks in advance.

Hi @bawenang_r! :wave:

I am sorry you ran into this issue. Could you please share a build link with us with Support Access enabled? This way we can take a deeper look and compare it to previous builds. If you’d rather share your build in a private message, please email us at and this will automatically create a support ticket. :blush: Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.