Always redirecting me to register device page

#1

I am a QA Tester for a company. I registered my iOS device to my account then i get an email to install the app. I pressed install then it redirects me to register device page. I pressed it again but nothing happens. I used Safari to open the page.

1 Like

#2

Hi @francemeister,

Thanks for reporting the issue here!

Can you please share a bit more details?

  • "i get an email to install the app": do you use a 3rd party email app on your iOS device or the iOS built in Mail app?
  • I used Safari to open the page.: did you use the actual Safari app, or can it be that you were in a webview inside your email app?
  • Did you try to open the page / install the app by opening bitrise.io and navigating to the related build?
0 Likes

#3

Hello,

Thanks for the help.
I used Gmail to open the email. Now I used the Mail app.
I then clicked the email again it opened it with Safari.
It then directs me to this (1). Then I clicked install. And it prompts this (2). I clicked okay but nothing happens.

0 Likes

#4

0 Likes

#5

Thanks for the details!

Can you please click the “clear cookies” link at the bottom of the install page, and then try it again?

0 Likes

#6

Did what you said sir. Registered the device again but still the same. It shows this

I click ok but nothing happens.

1 Like

#7

We tried to reproduce this issue but so far we could not unfortunately.

Can you please ping our support @francemeister with the link of this discuss thread, so that they can debug it?

0 Likes

#8

@francemeister we are also facing this problem and have not yet worked out why it is happening. Did you manage to resolve it?

0 Likes

#9

Hi @snowicki,

Can you please click the “clear cookies” link at the bottom of the install page, and then try it again?

If that wouldn’t help please ping our support via email or the onsite chat! :slight_smile:

0 Likes

#10

Thanks @viktorbenei , I tried the clear cache link but nothing changed. Its strange as we only see this problem on an iOS simulator but not on an Android simulator. It also works fine on all our physical iOS and Android devices. I’ll have a chat to support.

0 Likes

#11

Ohh I missed that you mentioned the Simulators. It’s a separate issue then I think @snowicki, the original one was for real / physical devices!

Can you please create a separate issue for the Simulator one, and share as many details as you can?

0 Likes

#12

@francemeister a similar issue was reported by another user. In his case the install did not happen on the public install page either, but it did work from the build’s page:

in iOS mobile Safari the eye & download icons should change to “Install”:

Can you please try to install the app from the build page and let us know how it goes, whether that helps?

0 Likes

#13

I was having the problem registering a device and clearing the History and Website data worked for me.

0 Likes