Cannot install build on newly migrated iPhone

My client had an iPhone 7 that he was previously using to install deploy builds from Bitrise successfully. He recently got a new iPhone 11 Pro. When he tries to install the app on his new phone, it gives him the error message

“This app is not allowed to be installed on this device. This device’s unique identifier (UDID) is {{{the old UDID from his iPhone 7}}} To view the list of the allowed test devices’ identifiers (UDIDs), visit the details page of the build which generated this app (publically not accessible).”

I’ve double checked via Xcode’s Devices and Simulators view, that the phone he’s trying has a valid UDID that is also listed in both the Apple Dev account and added to Bitrise and listed in the Bitrise app’s list of test devices. Our deploy workflow uses the iOS Auto Provision step. I also removed the old iPhone 7 UDID from Bitrise and disabled it in the Apple Dev account. Our other devices are able to install the build just fine. Also when he goes to Settings > General on his new phone, there are no Profiles installed on the new phone. Another thing worth mentioning is that when he migrated over to the new phone, he used the Quick Start bluetooth side-by-side method to get his data from his iPhone 7 to the 11 pro. (https://support.apple.com/en-us/HT210216)

Environment:

Where did the issue happen?

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share) Build from Bitrise.io

Which build Step causes the issue and which version of the step?

Deploy workflow uses iOS Auto Provision and Xcode Archive and Export for iOS

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO (Removed the cache steps)
  • Does the issue happen sporadically, or every time? : Every time only on this device
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : When he changed devices
1 Like

For anyone else that may run across this issue… It looks like we may have found a solution. I had my client delete the iPhone 11 Pro UDID from his Bitrise account and I re-added it from my account and now suddenly it prompted to install the profile again and it installed the app. I’m not quite sure why it worked though. I’ll post here if I get any more insight from Bitrise as to why they think this worked.

1 Like

Thank you @everydayodyssey-jess for logging this. I had the same issue. A client had migrated to a new iPhone 11 Pro from an iPhone X, and exactly as your original post described, the bitrise install page on Safari error message was referring to his old UDID from the iPhone X.

My client was successfully able to install after I had him clear his Safari browser cache:

I suppose the iPhone migration is very smart these days. :slight_smile:

For some humor: https://shouldiblamecaching.com/

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.