Xcode UI Test Build for testing fails

testing

#1

I’m trying out the new unit testing build step. Now, our project compiles just fine normally but I’ve put in the new build for testing step and I get a series of errors.

error: There are no accounts registered with Xcode. Add your developer account to Xcode (in target 'Multi App UI Tests')

Then an error saying it can’t find a provisioning profile for the test target and then an exit with error code 65.

Then Error writing xctestrun file: Error Domain=NSCocoaErrorDomain Code=4 "The folder “Multiple Society App_iphoneos12.1-arm64e.xctestrun” doesn’t exist." UserInfo={NSFilePath=/Users/vagrant/Library/Developer/Xcode/DerivedData/GDPC_First_Aid-dgryfgbfadrustfujbmiqgrczphc/Build/Products/Multiple Society App_iphoneos12.1-arm64e.xctestrun, NSUserStringVariant=Folder, NSUnderlyingError=0x7fab1def0550 {Error Domain=NSPOSIXErrorDomain Code=2 "No such file or directory"}}

I was using the auto-provision step, but I tried switching it out for the old certificate and profile installer with no luck.

I tried copy pasting the xcodebuild command that Bitrise runs for the build-for-testing step and running locally and it works just fine. Struggling to work out what is going on here. No idea why I would be getting provisioning errors when exporting and uploading to the app store works just fine normally in this workflow.

Any ideas?


#2

Hi @MattCheetham,

Sorry to hear about these issues. Can you please include a build URL for us to be able to look into this?


#3

#4

Hello there!
The thing here is that the auto provisioning only gets the profile for the main target, and you use a different target for UI test, so I would recommend the certificate and profile installer here.

In the future we will add this feature for the auto provision step as well but now it is just not possible.:confused: