XCode 9.2 / 9.4 / 10.0 Archive block with signed framework


#1

Bitrise Build Issue Report template

Description of the issue

The XCode Archive works well before, but from the 11th Feb, the Archive is blocked by a signed framework with this message.

XCode 9.2 / 9.4
Copying CATP/Classes/External/HereSDK/NMAKit.framework
skipping copy phase strip, binary is code signed: /Users/vagrant/git/CATP/Classes/External/HereSDK/NMAKit.framework/NMAKit
▸ Signing /Users/vagrant/Library/Developer/Xcode/DerivedData/CATP-fhrwwcdamjtfoucsakwxmirwrmti/Build/Intermediates.noindex/ArchiveIntermediates/Angouleme-AdHoc/InstallationBuildProductsLocation/Applications/Angouleme.app/Frameworks/NMAKit.framework

XCode 10 :
Copying /Users/vagrant/git/CATP/Classes/External/HereSDK/NMAKit.framework
skipping copy phase strip, binary is code signed: /Users/vagrant/git/CATP/Classes/External/HereSDK/NMAKit.framework/NMAKit

Environment:

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system?
Can be reproduce on stack
XCode 9.2 / 9.4 / 10.0

Which build Step causes the issue and which version of the step?
xcode-archive, version: 2.4.19

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? :
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? :
    The 11th Feb.

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

Build log

Sent with mail


#2

I have some more informations to update.

The problem is hanging at sign action for XCode Archive step.

We don’t upload the Certificate and Provisioning file to Bitrise.io, but stock it on our Git serveur.
We install the Certificate and Provisioning file with a fastlane command in Bitrise.io :
fastlane match adhoc

Every thing works fine until the 4th Feb. (we made our last build successful).

From the 11th Feb, that method doesn’t work anymore. The XCode Archive step is hanging at the sign action until 90 minutes timeout.
But if we upload the Certificate and Provisioning file to Bitrise.io, the build works again.

Could you check it and make the
fastlane match adhoc
work again ?

Thanks a lot.


#3

Hi,

I have resolved the problem.

I don’t know why our workflow worked before, and it doesn’t work now.

I resolved the problem by changing the order of the steps in the workflow.
Before :
1. Certificate and profile installer
2. Fastlane match adhoc --readonly
3. XCode Archive
Result :
The XCode Archive Step is hanging by the sign action

Update :
1. Fastlane match adhoc --readonly
2. Certificate and profile installer
3. XCode Archive
Result :
The Xcode Archive step passed with success.


#4

Hy there, I’m glad to hear that you could solve the issue yourself!


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.