XCode 11 Sign In - Archive Failed code 65

Bitrise Build Issue Report template

Description of the issue

After migration project to XCode 11.3 our Bitrise CI job is not able to build application archive anymore.
Also there are no useful error messages in Bitrise logs nor gym logs (even with --verbose and --capture_output flags)

Another important detail:

  1. We have updated all certificates and provision profiles (required by XCode 11) and uploaded them to Bitrise
  2. We are able to create valid .ipa locally via same fastlane script using exactly same certificate and provision profile

Job always fails on with same result:
Touching MyBaseApp.app
▸ Signing /Users/vagrant/Library/Developer/Xcode/DerivedData/Kingfisher-bmorbbkokrvxzkbofjrwhrykkpjh/Build/Intermediates.noindex/ArchiveIntermediates/MyBaseApp-TEST/InstallationBuildProductsLocation/Applications/MyBaseApp.app
ERROR [2020-03-20 14:25:33.36]: Exit status: 65


Xcode 11.3.x, on macOS 10.14.6 (Mojave)
fastlane_version “1.101.0” and “2.143.0” (tried both)

Where did the issue happen?
After migrating from XCode 10.3 to XCode 11.3

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? (Plus any other information you can share)
Xcode 11.3.x, on macOS 10.14.6 (Mojave)

Which build Step causes the issue and which version of the step?
Step: Create Archive:
gym(export_method: “enterprise”, export_options: { compileBitcode: false })


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. :NO
  • Does the issue happen sporadically, or every time? : Every Time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : After Xcode 10.3 → 11.3 project migration

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( Bitrise CLI )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: Redirecting… .

We didn’t try bitrise CLI, but fastlane job succeeded on local PC even with clean repository Clone. Also locally created .ipa file was successfully installed on iPhone devices

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - Contact us ), with a link to the related Discuss issue.

Hi @Vitalii.Kotivskyi, sorry to hear about the issue.

Unfortunately, the errors here are indeed not very helpful. Have you tried or considered using Bitrise solutions instead of fastlane? In case you do switch to our tools and those breaks, we could investigate that. more in-depth.

Unfortunately here we can mostly recommend to remote access into the machine and try running your lane manually, in hopes of finding out more information about the error. Please try that initially and let us know how that goes!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.