Why there is a firebase in /usr/local/bin?

#1

Bitrise Build Issue Report template

Description of the issue

When the firebase-app-distribution step trying to install npm packets,
it gets a error because a firebase file was already under /usr/local/bin path.

Environment:

Xcode 11.2.x, on macOS 10.14.6 (Mojave)
firebase-app-distribution@0.4.0 and 0.3.0

Before any steps got run, there is a firebase file under /usr/local/bin

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : sporadically, but almost every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Nov 17, 2019

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

NO

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

NO

Build log

0 Likes

#2

Hi,

I faced the same issue. To fix this I had to add a script workflow and add the following lines:

sudo rm -rf /usr/local/bin/firebase

This should not be necessary.

Please look into this.

Thanks.

0 Likes

#4

Hi,

This problem seems to be solved in version 0.5.0

1 Like