'Unable to Download App' when attempting to install app

I recently started getting an error pop-up on my iPhone ‘Unable to Download App’ when attempting to install my Xamarin app using Bitrise. A little bit of research lead me to conclude that this error means something went wrong during the signing process of the app, which makes sense since I’ve recently updated my provisioning profile. However, I’ve double-checked everything I can think of and still get the same error. Anyone have any ideas?

Here’s what I’ve tried so far:

  1. Created a new iOS development certificate from the Apple Developer Portal (i.e. created CSR file using Keychain, Upload to Apple Dev Portal, Downloaded Certificate, Export .p12 file).
  2. Double checked provisioning profile that it is using the correct Bundle ID, uses the newly created development certificate and contains my device ID.
  3. Double checked that my Entitlements.plist and Info.plist are both using the correct Bundle ID.
  4. On Bitrise, I’ve made sure the Provisioning Profile and p12 file I’ve uploaded are correct and have the correct password. The Bitrise builds are succeeding and the Build Logs indicate the correct provisioning profiles and certificates are being downloaded and installed.
1 Like

Figured out the issue! There was one extra entitlement checked in the Bundle ID used by my provisioning profile. So my entitlements plist was out-of-sync with the entitlements enabled in the provisioning profile. Am able to install the build now.

1 Like

Good catch and thanks for sharing the solution @clee46! :slight_smile: