Solved: No longer able to post generic project files (key "not unique")

#1

Prior to today I’ve been able to successfully use the API to create/upload generic project files. Currently, when I attempt to post a new generic project file my request is rejected because the key is not unique.

The documented curl example seems to fail in the same way:

`curl -X POST “https://api.bitrise.io/v0.1/apps/MYSLUGXXX/generic-project-files” -H “accept: application/json” -H “Authorization: MYACCESSTOKENXXX” -H “Content-Type: application/json” -d “{ “upload_file_name”: “Test-File”, “upload_file_size”: 4865, “user_env_key”: “TestFile9875”}”

{“message”:“Invalid request body: TestFile9875 key is not unique in repository, please use unique keys.”}`

The Code Signing tab for my project shows an entry as a result of the curl (see screenshot)

I’m assuming that provided the user_env_key value is unique to my app (or at least to my account) I should not be receiving this message.

Can anyone verify they endpoint is working as advertised for them? Am I missing anything?

0 Likes

#2

Hi @passacaglia! Thanks for your report, the endpoint is indeed not working, a fix in on the way, should be working again shortly!

0 Likes

#3

Hi passacaglia,

Thank you for your remark. You got a confusing error message when you tried to upload files with unique keys.
We have found the issue and just created a small patch.

Thank you for your patience and have a nice day,

1 Like

#4

Resolved! Thanks for the quick turnaround.

2 Likes