'RCTOneSignalExtensionService.h' file not found


#1

Description of the issue

Unable to build on Bitrise but works locally (iOS)

Please describe the issue here

Receiving error

/Users/vagrant/git/ios/OneSignalNotificationServiceExtension/NotificationService.m:1:
9: fatal error: 'RCTOneSignalExtensionService.h' file not found
#import <RCTOneSignalExtensionService.h>
        ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
1 error generated.

Environment:

MacOS 10.14.2 Mojave,

Where did the issue happen?

MacOS

Which build Step causes the issue and which version of the step?

xcode-test@2.0.0

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Since the app was created

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried. No, tried all sections for iOS

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.
https://app.bitrise.io/build/0d42d32b7a279864


#2

Hello there!

You will need to install the required dependencies to be able to build your application! :upside_down_face:
I recommend adding the Install react native step, an npm step with install command, and a cocoapods install step as well. it may throw a bundler error in that case a react native bundle step is advised as well.

I hope you will be able to succeed!


#3

Ah, yes, good catch! I will add the proper step to install the deps, can’t believe I didn’t realize that was missing aha since I used the iOS prebuilt steps, this makes sense it didn’t install RN deps.

Thank you!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.