Xcode-test build failed on Bitrise CLI

ios

#1

Bitrise Build Issue Report template

Description of the issue

I set up my project using Bitrise CLI tool and followed the instruction. It works on Bitrise.io but I download the bitrise.yml file and put it in the project folder to run locally, I got the error below for the Xcode-test step:

WARN[13:07:50] Installing Step dependency failed, retrying …

WARN[13:07:50] Installing Step dependency failed, retrying …
ERRO[13:07:50] Step (xcode-test@1.18.16) failed, error: Failed to install Step dependency, error: The full Xcode app is not installed, required for this step. You can install it from the App Store.

I have my Xcode installed on my Macbook and I can use it with no issues for development. I think I may miss some part for creating the dependency?

Environment:

Where did the issue happen?

The same bitrise.yml file works on Bitrise.io but failed on Bitrise CLI tool.

Which build Step causes the issue and which version of the step?

xcode-test@1.18.16 (exit code: 1)

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Two days ago when I tried to set up my project to Bitrise CLI tool.

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what bitrise.io will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Local reproduction: Linux / Android (docker based) stack builds

Can it be reproduced by running the build locally, after doing a new git clone of the repository into the /tmp directory and running the build from there with the Bitrise CLI ( https://www.bitrise.io/cli )? If no, can it be reproduced with Docker (using the same docker images / environment we use on bitrise.io)? Related guide: http://devcenter.bitrise.io/docker/run-your-build-locally-in-docker/ .

Build log

Please copy paste the build’s bitrise.io URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - https://www.bitrise.io/contact ), with a link to the related Discuss issue.


#2

Remove xcode test from workflow (y)


#3

As the error states, to do an Xcode Test you have to install Xcode.app
Just the command line tools are not enough.
Please install Xcode.app from the AppStore then it’ll work on that Mac :wink:


#4

Hi,

I mentioned I have Xcode app installed on my Macbook and it works with no issues for the app development. But when I run the Xcode test step on the Bitrise CLI it still gives me this error. ;( Don’t know what’s missing. I tried with the sample app with test and it gives me the same error. Is there anything else I need to do besides Xcode installed?

Thanks!


#5

Hi @katherineli0514,

do you have Xcode’s command line tools installed?
What is the output of: xcodebuild -version on your local machine?


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.