Github repo cannot be found

Bitrise Build Issue Report template

Description of the issue

Bitrise was building my github repo fine until recently, or say today. The build fails at git-clone and I got error “Repository not found” and “fatal: could not read from remote repository”. The exit status is 128.

I tried to rebuild a build job, which was successful before. It also failed with same error.

I tried to init, add, fetch, and checkout in terminal on my mac and they all worked fine.


Bitrise stack: Xcode 9.2.x, on macOS 10.12 (Sierra)

Which build Step causes the issue and which version of the step?
id: git-clone |
version: 4.0.5


  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : Every time
  • Does upgrading the build Step to the latest version help? : NO
  • When did the issue start? : Today

Local reproduction

Can it be reproduced on your own Mac/PC by following our local debug guide? Please follow at least the first section (“Testing with a full clean git clone”) to make sure to test the state of the code what will get when it does a git clone in the clean environment! If possible please note which sections you tried.

Build log

Please copy paste the build’s URL here (or if the issue happens somewhere else then the full logs), or if you can’t share the url / log here then send the url or full log through a private channel (e.g. email - ), with a link to the related Discuss issue.

Here are the messages I got in Bitrise bulid log.
git "init"
Initialized empty Git repository in /Users/vagrant/git/.git/
git “remote” “add” “origin” "[my github repo url]"
git "fetch"
Warning: Permanently added ‘,’ (RSA) to the list of known hosts.
ERROR: Repository not found.
fatal: Could not read from remote repository.


Hey @jial_apa !

Could you please send us your build log on our on-site chat, so we can have a closer look?
Thanks in advance.

1 Like

i have same issue did you solved it ?

Hi @askari01!

Can you please contact us on our on-site chat and send us your build URL or log file too? :slight_smile:

1 Like