Provisioning profile "App Name" doesn't include the entitlement

Hey Guys,


:x: error: exportArchive: Provisioning profile “App Name” doesn’t support the Associated Domains capability.
:x: error: exportArchive: Provisioning profile “App Name” doesn’t include the entitlement.

I am getting a variety of signing issues that I’m not getting with an Xcode Build. This capability is definitely enabled in the entitlement file. I don’t understand why it’s not getting picked up by bitrise. Any assistance would be appreciated

1 Like


Thanks for creating this issue report! :slight_smile:

It seems that you tried to create an App Store signed IPA, and you did upload matching signing files, but those are most likely outdated and do not include the listed capabilities (Provisioning profile “App Name” doesn’t support the Associated Domains capability.).

Can you please:

  1. Open the portal
  2. Download the app’s App Store distribution provisioning profile from there
  3. And upload it to

Please do not delete the previous provisioning profiles on, only the app store distribution one which you replace with the new one (but even that isn’t necessary usually).

Please let us know how it goes or if you have any questions! :slight_smile:

Tech note:

The capability have to be enabled in both the project (from the logs it seems it is) as well as in the Provisioning Profile, and it seems the profile you uploaded to is probably and older profile and does not include these capabilities.

Hi @viktorbenei,

I believe I did that. I created a new Distribution Profile “ElsewhereQA_Xcode9” and uploaded that to bitrise. I also turned off pull requests for other profiles to try and make sure that the right profile is used. Could it be that they are cached?
Also the associated domains are turned on for both.

Can you please include the related build’s log? The one after you uploaded this file @SWARM

Hi @viktorbenei,

Are you able to access the logs from here:

If not I’ll upload them manually.

We can, thank you! :slight_smile: We’ll look into it ASAP!

Actually, this link seems to be the same you copied the first time - can you please copy paste the new build’s URL? The one which you ran after you uploaded the new Prov Profile.

I had uploaded the profile before starting the build. It’s the same. I was thinking of starting a new build by deleting the old profiles. I just disabled the pull on them for this build.

@SWARM we just released a new Xcode Archive step version (2.3.6) - can you please upgrade to that and run a new build? If that would’t help please copy paste the new build’s url here :slight_smile:

1 Like

Closing as the issue should be solved now with the latest step version - if you’d still have the issue @SWARM please fill out a new #issues:build-issues report and we’ll check it ASAP! :slight_smile: