Provisioning profile "BitriseBot-Wildcard" doesn't match the entitlements

Bitrise Build Issue Report template

Description of the issue

The iOS app build is keep failing on below error. It is my first build in Bitrise and I’m new to Bitrise. I’m not sure what is causing this issue. Please help me out.

Environment: iOS Build

Where did the issue happen? The stack is Hybrid (Xamarin, Ionic, …) on macOS, includes Visual Studio for Mac, Stable channel

Which build Step causes the issue and which version of the step?

xcode-archive 2.4.5

Build log

error: exportArchive: Provisioning profile “BitriseBot-Wildcard” doesn’t match the entitlements file’s value for the application-identifier entitlement.
If you can’t find the reason of the error in the log, please check the raw-xcodebuild-output.log
The log file is stored in $BITRISE_DEPLOY_DIR, and its full path
is available in the $BITRISE_XCODE_RAW_RESULT_TEXT_PATH environment variable
2018-02-02 21:58:05 +0000 [MT] Step failed: <IDEDistributionSigningAssetsStep: 0x7fc30eeced70>: Error Domain=IDEDistributionSigningAssetStepErrorDomain Code=0 “Locating signing assets failed.” UserInfo={NSLocalizedDescription=Locating signing assets failed., IDEDistributionSigningAssetStepUnderlyingErrors=(
“Error Domain=IDEProfileQualificationErrorDomain Code=8 “Provisioning profile “BitriseBot-Wildcard” doesn’t match the entitlements file’s value for the application-identifier entitlement.” UserInfo={IDEProfileQualificationError_Profile=<DTDKProvisioningProfile 0x7fc30eebea20: UUID: 335312dd-6845-475f-959b-9bbae2f97a3e, name: BitriseBot-Wildcard, team: 72SA8V3WYL (BITFALL FEJLESZTO KORLATOLT FELELOSSEGU TARSASAG), platform: iOS>, NSLocalizedDescription=Provisioning profile “BitriseBot-Wildcard” doesn’t match the entitlements file’s value for the application-identifier entitlement.}”

Hi @aditya.gupta,

Thanks for reporting the issue here! :slight_smile:

Please run our codesigndoc tool on your Mac and upload all the files it collects, that should help:

Let us know how it goes or if you’d have any questions! :slight_smile:

Thanks for replying Viktor!

I did run the codesigndoc tool and upload all the provisioning and certificate files before reporting the issue here. I also tried with uploading code signing files without running codesigndoc tool. That also did not help me.


@aditya.gupta can you please enable Support Access on the Settings tab of the app? I’ll check it ASAP!

I have enabled Support access for the app "react-native-nw-react-calculator’.


I tried to open the build you originally linked but could not access it with a support account. Are you sure that you enabled support access for the right app? It seems the build you linked belongs to another app.

My bad! I enabled the support on another app. I have enabled it now for the right app “NativeBase-KitchenSink”.

Sorry about that.


Checking it right now! :slight_smile:

So the issue seems to be that you uploaded a dev signing file pair but for a different bundle ID.

The Bundle ID of the profile you uploaded is: com.REDACTED.bitrise.demo

But the (Xcode) project’s Bundle ID is org.reactjs.native.example.REDACTED

You can see this in the log of the Xcode Archive step, around these lines:

e[34;1mExporting ipa from the archive...e[0m

Exporting ipa with ExportOptions.plist
No custom export options content provided, generating export options...
export-method specified: development
xcode major version > 9, generating provisioningProfiles node

Target Bundle ID - Entitlements map

Thanks for pointing out the issue. I have corrected the issue and build is successful now.

My next question is,
How can I deploy the IPA and APK to testflight? Do you have a guide on how to do that?


Awesome, glad to hear! :slight_smile:

To TestFlight you can only upload the IPA, the APK should go to Google Play (just to be sure ;)).

For Google Play: simply add the Google Play Deploy step and follow the guide in its description.

For TestFlight/App Store deploy: How to deploy to iTunes Connect TestFlight?