Pods - Double quoted "" include framework header

#1

Bitrise Build Issue Report template

Description of the issue

Unable to build at xcode-test@2 step because Pod files import modules using double quotes “”. Eg.:

#import “SomeModelue.h”

You can solve this in Pods-> Build Settings as shown in this article, but I can’t figure out where am I supposed to set an Xcode Build Setting with Bitrise.

I was able to build it successfully by using remote access and changing this setting in Xcode there, but I don’t know how I can do this for every build, as far as I understand, the builds are not made by the same computer necessarily right? This setting is correctly configured in my project so I would assume that when git clones my project all the settings remain the same when building it remotely, however, seems like that is not the case. I keep getting:

:x: /Users/vagrant/git/Pods/GoogleDataTransport/GoogleDataTransport/GDTCCTLibrary/Protogen/nanopb/cct.nanopb.h:22:10: could not build module ‘nanopb’
#include <nanopb/pb.h>

Environment:

Where did the issue happen?

If on Bitrise.io: which stack? If not on Bitrise.io: on what operating system? Xcode 12.3

Which build Step causes the issue and which version of the step?

xcode-test@2

Reproducibility

  • Does a “Rebuild” help? (You can trigger a rebuild from the Build’s page, by clicking the “Rebuild” button in the top right corner of a finished build) : NO
  • Does a rebuild without caches help? (You can remove the Cache:Pull and Cache:Push steps temporarily to not to use the cache, or you can delete all the caches on the Settings tab of the app. : NO
  • Does the issue happen sporadically, or every time? : YES
  • Does upgrading the build Step to the latest version help? : YES
  • When did the issue start? : first time use

Build log

0 Likes

#2

I realized that one of the steps installed the pods every time I run it so that must have been messing up with the Pods.xcproj and that’s why my local and remote projects differed. Removing the step solved the issue.

0 Likes

#3

Thank you for reaching out!

Glad you were able to resolve your issue, something to also consider if you’re still having issues is:

set CLANG_WARN_QUOTED_INCLUDE_IN_FRAMEWORK_HEADER to NO for all Pods build settings

Take care!

Thi

0 Likes