Build error with xcode12

#1

My project compiles correctly in xcode12 on my machine.
The configuration to correct this double quote error has already been made, (which is to set this field below in the xcode CLANG_WARN_QUOTED_INCLUDE_IN_FRAMEWORK_HEADER = NO) but the bitrise continues to give this error. I would like to try to understand why and also understand why bitrise did not use the xcode variable I set up for this.

I need help with this because I already tried several solutions but the bitrise keeps giving me this error.

ps. sorry about my English.

Error ocurred:

:x: /Users/vagrant/git/Pods/Target Support Files/nanopb/nanopb-umbrella.h:22:9: double-quoted include “pb_common.h” in framework header, expected angle-bracketed instead [-Werror,-Wquoted-include-in-framework-header]
#import “pb_common.h”
^~~~~~~~~~~~~
:x: /Users/vagrant/git/Pods/GoogleDataTransport/GoogleDataTransport/GDTCCTLibrary/Protogen/nanopb/cct.nanopb.h:22:10: could not build module ‘nanopb’
#include <nanopb/pb.h>

0 Likes

#2

I solved, just update cocoapods version to 1.10.0

1 Like

#3

Hi Marcal, I have been struggling with the same issue for a while, and your post is the first one to be related to Bitrise which is in other words related to building the project using the command line and passing the option as part of that command, not changing it from the xcode build settings as all the answers I found are suggesting. However, I tried my best to understand from your answer how I should solve the issue. I tried adding the part you mentioned CLANG_WARN_QUOTED_INCLUDE_IN_FRAMEWORK_HEADER=NO to be an extra option added to the build but I got the same error, so my question is: should I put that option with the exact name you mentioned? am I doing it right? am I missing anything? any help would be appriciated.

0 Likes